Signalerstellung und -Sampling in Labview

Signal -erfassung, -verarbeitung und -ausgabe

Signalerstellung und -Sampling in Labview

Postby mohsen_sefati on 11 Nov 2011, 19:05

Hallo Zusamman,

ich bin relativ neu und habe noch nicht so viele Erfahrung in LabView. Ich arbeite mit einem NI- USB 5269 und möchte mit diesem DAQ einen Prüfstand regeln.

Zunächt möchte ich zwei einfache sinusförmige Signale so erstellen, dass die Freq. und Amp. der Sinus-Signale während der Ausgabe veränderbar sind. Freq. dieser Signale sollen zwischen 1 HZ bis 1 kHZ einstellbar sein. Ich habe bereits für jedes Ausgabesignal ein Kanal im 'Measurement und Atomation' definiert und habe diese Kanäle wie folgend eingestellt:
NI-DAQmx-Task:
actuator: Signalerzugungsmodous: 1 Sample(on Demand) max 10 Volt und min -10 Volt
shaker: Signalerzugungsmodous: 1 Sample(on Demand) max 10 Volt und min -10 Volt

Zur Erstelung dieser zwei sinusförmigen Signale, habe ich beide 'DAQ-Assistent' und 'DAQmx-Schreiben' probiert.

beim 'DAQmx-Schreiben' wird das Signal erst erstellt, wenn Signalerzeugunsmodous des Kanals '1 Sample(On Demand)' ist. Die Signalqualität bei den höheren Frequenzen (100 HZ) ist schlecht( die Auflösung beträgt 1 ms). Wenn ich das '1 Sample(On Demand)' auf Kontinuierlich oder N-Samples ändere, wird dann kein Signal erstellt und wenn ich 'Samples pero sekunde' des 'Signal Simulieren-Block' auf 10KHz erhöhe, wird die Freq. des Ausgabesignals verfälscht! könnt ihr bitte mir sagen warum?! was ich da falsch mache?!

beim 'DAQ-Assistent' sehen die Signale mit der Frequenz unter 10 Hz sinusförmig aber gestrichelt aus! das weiß ich auch nicht warum!!

Ich bedanke mich für eure Antwort

Besten Dank
Mo
Attachments
DAQ-Assistent.vi
(73.05 KiB) Downloaded 83 times
DAQmx-schreiben.vi
(35.88 KiB) Downloaded 87 times
mohsen_sefati
interested
interested
 
Posts: 1
Joined: 11 Nov 2011, 16:31
LabVIEW Version: 9.0.1 31 Bit
Karma: 0

Return to Signalverarbeitung

Who is online

Users browsing this forum: No registered users and 2 guests

cron